anet a6 problem z silnikiem Y

szkapcio
Posty: 4
Rejestracja: 23 wrz 2018, 00:53

anet a6 problem z silnikiem Y

Postautor: szkapcio » 23 wrz 2018, 00:57

Witam,kiedy wchodzę w ręczne ruszanie osiami to silnik Y idzie tylko w jedna stronę,podłączyłem silnik X na miejsce Y i dalej to samo ale kiedy podpinam Y w miejsce X to już chodzi.
Tu moje pytanie do tych co się znają lepiej,uwalona płyta główna czy coś można działać w firmware
Awatar użytkownika
dziobu
Zasłużony
Posty: 2557
Rejestracja: 28 gru 2016, 16:38
Lokalizacja: Kraków
Drukarka: ZMorph 2.0(S)
x 714
Kontaktowanie:

Re: anet a6 problem z silnikiem Y

Postautor: dziobu » 23 wrz 2018, 02:20

Sprawdź krańcówki dla osi Y.
Jeśli są OK, to zobacz czy linia DIR (dla osi Y) zmienia stan przy zmianie kierunku jazdy.
Pozdrawiam
Paweł

Moje twory w 3D
szkapcio
Posty: 4
Rejestracja: 23 wrz 2018, 00:53

Re: anet a6 problem z silnikiem Y

Postautor: szkapcio » 23 wrz 2018, 11:44

Krańcówka jest jedna i działa, mógłbyś powiedzieć jak sprawdzić stan przy zmianie kierunku?
Awatar użytkownika
dziobu
Zasłużony
Posty: 2557
Rejestracja: 28 gru 2016, 16:38
Lokalizacja: Kraków
Drukarka: ZMorph 2.0(S)
x 714
Kontaktowanie:

Re: anet a6 problem z silnikiem Y

Postautor: dziobu » 23 wrz 2018, 13:57

A skąd wiesz że działa? Nie pracuje odwrotnie?
Silnik jedzie w jednym kierunku:
- gdy stoi na krańcówce - soft chce z niej zjechać; wciśnij krańcókę ręcznie i spróbuj jechać w drugą stronę (jeśli to zadziałą to zaneguj tą krańcókę),
- gdy ma blokadę programową (programowa krańcówka; jak jesteś na pozycji "0" to w dół nie pojedziesz, musisz odjechać i wtedy spróbować),
- gdy linia DIR do stepsticka ma stały stan (zwarcie) - wtedy stepstick jedzie zawsze w jedną stronę.

Ostatni punkt - możesz mieć zwarcie na głównej POB albo na stepsticku. Najprościej - zamień stepsticki z osi X i Y i daj znać co to zmieniło.

A fizyczny stan linii możesz sprawdzić miernikiem, oscyloskopem, sondą logiczną...
Pozdrawiam
Paweł

Moje twory w 3D
szkapcio
Posty: 4
Rejestracja: 23 wrz 2018, 00:53

Re: anet a6 problem z silnikiem Y

Postautor: szkapcio » 23 wrz 2018, 14:18

do Y podłączyłem stepsticka od X i dalej nie mogę ruszyć stołem w jedną stronę ,stepstick od Y według miernika- działa zwarty i rozwarty.
Kiedy daje teraz pozycje zerową stół rusza się możne milimetr w jedna stronę


edit:faktycznie stół jedzie kiedy trzymam krańcówkę,zaraz zmienię i dam znać
szkapcio
Posty: 4
Rejestracja: 23 wrz 2018, 00:53

Re: anet a6 problem z silnikiem Y

Postautor: szkapcio » 23 wrz 2018, 15:13

niestety po próbach po ustawieniu auto home stół Idze w druga stronę niż stepstick,kiedy nacisnę go ręcznie stół nie idzie w druga stronę tylko staje
Awatar użytkownika
dziobu
Zasłużony
Posty: 2557
Rejestracja: 28 gru 2016, 16:38
Lokalizacja: Kraków
Drukarka: ZMorph 2.0(S)
x 714
Kontaktowanie:

Re: anet a6 problem z silnikiem Y

Postautor: dziobu » 23 wrz 2018, 23:54

szkapcio pisze:niestety po próbach po ustawieniu auto home stół Idze w druga stronę niż stepstick,kiedy nacisnę go ręcznie stół nie idzie w druga stronę tylko staje

Jakie ustawienie auto home? Jak w drugą stronę niż stepstick? Nie rozumiem powyższego tekstu.
Pozdrawiam
Paweł

Moje twory w 3D
Awatar użytkownika
Cosik
Posty: 400
Rejestracja: 09 gru 2017, 10:12
Lokalizacja: Wrocław
Drukarka: Mono Zircon, AA6
x 63
Kontaktowanie:

Re: anet a6 problem z silnikiem Y

Postautor: Cosik » 24 wrz 2018, 08:29

Wiesz co nie napisałeś czy zmieniałeś firmware, bo to wygląda tak jakbyś nie zrobił Home dla osi. Są takie przypadki że jedzie tylko w jedną stronię do momentu gdy nie zrobiż "hołmowania" osi.
Wolność wariacie w swoim warsztacie...

Moje projekty 3D
Awatar użytkownika
Kopytko
Zasłużony
Posty: 3094
Rejestracja: 19 kwie 2016, 11:27
Lokalizacja: Oleśnica
Drukarka: P3Steel v4.00
x 396

Re: anet a6 problem z silnikiem Y

Postautor: Kopytko » 28 wrz 2018, 10:22

Odwróc wtyczke silnika stołu o 180 stopni :)
:arrow: Pozdrawiam Patryk.
Aktualne drukarki :
:idea: Prusa i3 w wersji p3steel v1.00 :idea: Prusa i3 2 wersji p3steel v4.00 long :idea: Replicator 1 by CTC :idea: Delta Kossel :idea:UM2+extended
W budowie : COSIEK 70x70x70 :devil:
Awatar użytkownika
Cosik
Posty: 400
Rejestracja: 09 gru 2017, 10:12
Lokalizacja: Wrocław
Drukarka: Mono Zircon, AA6
x 63
Kontaktowanie:

Re: anet a6 problem z silnikiem Y

Postautor: Cosik » 28 wrz 2018, 12:31

Jak ja to kocham, temat umarł i nie wiadomo czy działa, czy nie, eh....

Może warto posprzątać takie martwe tematy? Bo one nic nie wnoszą.
Wolność wariacie w swoim warsztacie...

Moje projekty 3D

Wróć do „Mechanika”

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 1 gość