Problem z silnikami/reglami

Quadcoptery i inne bajery
Awatar użytkownika
marek91
Administrator
Posty: 1847
Rejestracja: 15 kwie 2016, 21:22
Lokalizacja: Łaziska
x 394
Kontaktowanie:

Problem z silnikami/reglami

Postautor: marek91 » 29 lis 2017, 12:16

Mimo moich najszczerszych starań silniki działają jak chcą.
Silniki pracują tak jakby gubiły kroki, tz. nieregularnie.

Tz. przy dodawaniu gazu:
-silnik 1 uruchamia się prawie zawsze
-silnik 2 uruchamia się w 75% przypadków
-silnik 3 j/w
-silnik 4 nie uruchamia się prawie wcale

Uprzedzając pytania:
-Mam zaprogramowane CC3D
-Próbowałem ustawić "punkt startowy" dla silników, nie pomogło, nie ważne czy dam 1100 czy 1400us
-Robiłem programowanie regulatorów "od zera"
-podłączyłem każdy silnik od odbiornik bez cc3d, sytuacja taka sama jak opisałem powyżej
-asekuracyjnie przemierzyłem rezystancję na obwodach silników, wszystkie mają na wszystkich obwodach ok 0,4 oma

Podejrzewam że to badziewne regulatory, choć pewności nie mam.

ESC to simonk 12A
silniki 2204 2300kV

Cały zestaw tu:
https://www.aliexpress.com/item/Carbon- ... 0.0.jE68u6

Przekopałem pół internetu i jutuby, sporo ludzi ma ten sam problem, nikt nie ma skutecznego rozwiązania.
Awatar użytkownika
morf
Posty: 541
Rejestracja: 17 sty 2017, 12:28
Drukarka: X3D XL
x 84

Re: Problem z silnikami/reglami

Postautor: morf » 29 lis 2017, 12:30

Skoro zrobiles rzetelnie kalibracje ESC i nadal nic nie dziala

źródło: https://www.youtube.com/watch?v=N1IOXfft85s
te esc wywal najlepiej do kosza :-)

simonK to tak na prawde nazwa FW, ktory powinien byc na nie wgrany (prawdopodobnie nie jest).
To sa ESC niby z BEC 5V/1A co akurat jest Ci zupelnie nie potrzebne w kopterze. Szczegolnie cztery razy :-)

Kup cos *normalnego* nawet najtansze dys opto BL20A mini lub cos podobnego - beda lepsze :-)
kolejny przyklad ze tanie kity nie nadaja sie

PS. Nie wiem czy librepilot ogarnia w ogole oneshot/dshot wiec jesli chcesz zostac przy cc3d to i tak ledwo openshot ma sens, ale tylko na sofcie betaflight
Awatar użytkownika
marek91
Administrator
Posty: 1847
Rejestracja: 15 kwie 2016, 21:22
Lokalizacja: Łaziska
x 394
Kontaktowanie:

Re: Problem z silnikami/reglami

Postautor: marek91 » 29 lis 2017, 12:53

Morf, tą kalibrację robiłem ze 20 razy, bezskutecznie, silniki startują losowo.

dys opto BL20A dostępnie głównie na aliexpress

Też podejrzewałem że te regle to chiński chłam :devil:
mcxmcx
Posty: 765
Rejestracja: 09 kwie 2017, 21:32
x 38

Re: Problem z silnikami/reglami

Postautor: mcxmcx » 29 lis 2017, 13:13

Ale sprawdziłeś ile pwm ci wychodzi z odbiornika?
Awatar użytkownika
morf
Posty: 541
Rejestracja: 17 sty 2017, 12:28
Drukarka: X3D XL
x 84

Re: Problem z silnikami/reglami

Postautor: morf » 29 lis 2017, 13:19

Może być coś innego 20a opto. Popatrz na allegro ew mogę podać parę różnych sklepów online ale nie chce robić reklamy
Awatar użytkownika
marek91
Administrator
Posty: 1847
Rejestracja: 15 kwie 2016, 21:22
Lokalizacja: Łaziska
x 394
Kontaktowanie:

Re: Problem z silnikami/reglami

Postautor: marek91 » 29 lis 2017, 13:59

Wrzucaj śmiało :)

PWM - napisz więcej )
Awatar użytkownika
morf
Posty: 541
Rejestracja: 17 sty 2017, 12:28
Drukarka: X3D XL
x 84

Re: Problem z silnikami/reglami

Postautor: morf » 29 lis 2017, 15:24

marek91 pisze:Wrzucaj śmiało :)

PWM - napisz więcej )


Przykladowych pare linkow z allegro/sklepow (kolejnosc losowa)
http://allegro.pl/regulator-esc-dys-xs2 ... 36405.html
http://allegro.pl/regulator-esc-emax-li ... 15332.html
http://allegro.pl/regulator-esc-racerst ... 79342.html
https://abc-rc.pl/regulator-skyrc-blheli-nano-20a-2-4s
http://xdrony.pl/p/518/21065/zestaw-reg ... atory.html


ew mam troche szpeji "z demontazu" jakby Cie interesowalo tez uzywane to daj znac PW

Do tego dokup jeszcze jakiegos BEC 5V np 3A do zasilania odbiornika lub samego cc3d
Awatar użytkownika
marek91
Administrator
Posty: 1847
Rejestracja: 15 kwie 2016, 21:22
Lokalizacja: Łaziska
x 394
Kontaktowanie:

Re: Problem z silnikami/reglami

Postautor: marek91 » 29 lis 2017, 15:53

Czekaj bo nie wiem czy dobrze rozumiem, mam mieć 3 szt z jednego rodzaju i 1 szt inną? To będzie działać?
Awatar użytkownika
morf
Posty: 541
Rejestracja: 17 sty 2017, 12:28
Drukarka: X3D XL
x 84

Re: Problem z silnikami/reglami

Postautor: morf » 29 lis 2017, 17:08

4x opto ESC (zakladam ze masz quad kopterka) + osobny ubec 5V(to jest taka mala przetwornica na 5V zeby zasilac cc3d/odbiornik.
Chodzi o to ze to co miales do tej pory mialo wbudowany BEC (3 przewody we wtyczce) przez ktore najprawdopodobniej zasilales cc3d
Awatar użytkownika
marek91
Administrator
Posty: 1847
Rejestracja: 15 kwie 2016, 21:22
Lokalizacja: Łaziska
x 394
Kontaktowanie:

Re: Problem z silnikami/reglami

Postautor: marek91 » 29 lis 2017, 19:56

Ok teraz rozumiem, czyli ten Ubec muszę podłączyć z jednej strony do płytki rozdzielającej zasilanie a z drugiej wpiąć go do cc3d?

Do którego portu? 4 pierwsze są zajęte przez regulatory... piąty? szósty? bez różnicy?

Kolejne głupie pytanie... czy cc3d musi być dokładnie na środku coptera? Gdzieś czytałem że ma to znaczenie...
Teraz mam zamontowane z przodu, na środku jest bateria, bo ciężka, chciałem przykręcić nad płytkę rozdzielającą zasilanie ale tu przeszkadza mi port mini usb...

Wróć do „Robotyka, modele RC, modelarstwo”

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 1 gość