Rozwiązania i problemy przy budowie siboor Voron 2.4 350

Wszelka okazjonalna pomoc i wsparcie. Zbiórki, projekty i wydruki pomocowe, itp. Wszystko dotyczące sytuacji których nikt nie chciał a niektórzy doświadczają.
Problem z drukarką? - to NIE tutaj.
procesor82

Re: Rozwiązania i problemy przy budowie siboor Voron 2.4 350

Post autor: procesor82 »

Zrobiłem jak mówisz tam robi się to samo co w pliku config i nie działa to, a następstwem jest to ze już nie mogę włączyć lan i muszę na nowo robić kartę żeby uzyskać dostęp do maszyny. I co tu robić ?
procesor82

Re: Rozwiązania i problemy przy budowie siboor Voron 2.4 350

Post autor: procesor82 »

majek pisze: 11 wrz 2023, 19:26 Wygląda ok.
Zmieniłeś mu nazwę? Znika z karty po uruchomieniu?
Nie dodawałeś mu jakiś enterów czy czasem jakiś edytor mu nie przekonwertował końców linii? Najlepiej to w samym notatniku edytować i nie dotykać końców linii.
Zmieniłem i znika, tylko po lanie się łączy oczywiście do momentu zmiany w tym pliku na wi fi wtedy nie mam dostępu juz ani do lan ani wifi.
procesor82

Re: Rozwiązania i problemy przy budowie siboor Voron 2.4 350

Post autor: procesor82 »

Trolinka pisze: 11 wrz 2023, 19:55 A nie prościej zdebugować jak biały człowiek co się dzieje? :-)
Sprawdzić (iwconfig / ifconfig) czy w ogóle są interfejsy, sprawdzić logi (cd /var/log;grep -i wlan *)
A tak to nie wiadomo czy plik prawidłowy, czy hasło , czy z routerem się nie dogaduje etc.

PS. Z tego co piszą ten automatyczny plik owszem wszystko ustawia ale.....tylko raz przy pierwszym starcie ambiana. Teraz już go ignoruje.
Settings below will be applied only on 1st run of Armbian
Nie wiem jak to zrobić bo po zmianie ustawienia na wifi nie mam potem dostępu ?
procesor82

Re: Rozwiązania i problemy przy budowie siboor Voron 2.4 350

Post autor: procesor82 »

Zrobiłem taki myk create /etc/wpa_supplicant/wpa_supplicant.conf i dopiero armbian-config i poszło :).
procesor82

Re: Rozwiązania i problemy przy budowie siboor Voron 2.4 350

Post autor: procesor82 »

Za drugim razem wyłącz i włącz i po internecie ani lan ani wi fi :(
Awatar użytkownika
konradsdev1
Postów w temacie: 7
Posty: 467
Rejestracja: 30 wrz 2020, 16:55
Lokalizacja: Warszawa
Drukarka: VORON 0
x 184

Re: Rozwiązania i problemy przy budowie siboor Voron 2.4 350

Post autor: konradsdev1 »

Za pomocą pliku ustaw tylko LAN. W komentarzu jest napisane, że można w ten sposób włączyć tylko jeden z interfejsów.

Kod: Zaznacz cały

# Enable WiFi or Ethernet.
# NB: If both are enabled, WiFi will take priority and Ethernet will be disabled.
NC_net_ethernet_enabled=1
NC_net_wifi_enabled=0

NC_net_use_static=1
NC_net_static_ip='192.168.0.100'
NC_net_static_mask='24'
NC_net_static_gateway='192.168.0.1'
NC_net_static_dns='1.1.1.1'
Jak już połączysz się przez LAN to możesz dodać połączenie WiFi ręcznie za pomocą komend:

Kod: Zaznacz cały

FR_net_wifi_ssid='moja nnazwa'
FR_net_wifi_key='mmoj klucz'
FR_net_wifi_countrycode='PL'
FR_net_static_ip='192.168.0.101'
FR_net_static_mask='24'
FR_net_static_gateway='192.168.0.1'
FR_net_static_dns='1.1.1.1'
FIXED_IP_SETTINGS="ipv4.method manual ipv4.address ${FR_net_static_ip}/${FR_net_static_mask} ipv4.dns ${FR_net_static_dns} ipv4.gateway ${FR_net_static_gateway}"
iw reg set "$FR_net_wifi_countrycode"
nmcli con add con-name "Armbian wireless" type wifi ifname wlan0 ssid "$FR_net_wifi_ssid" -- wifi-sec.key-mgmt wpa-psk wifi-sec.psk "$FR_net_wifi_key" ${FIXED_IP_SETTINGS}
Polecenie "nmcli con show" powinno wyświetlić dwie sieci:

Kod: Zaznacz cały

NAME                UUID                                  TYPE      DEVICE
Armbian ethernet   9de0797f-7c37-35c2-167d-8cdfe195414c  ethernet  eth0
Armbian wireless   ca27b8bd-6737-41b4-2f49-5123fced1e42  wifi      wlan0
Na koniec sprawdź czy się powiedzie:

Kod: Zaznacz cały

nmcli con up "Armbian wireless"
"Everybody needs a hobby" (Tony Stark).
VORON V0.2 (BTT SKR Pico + RPi 4B + Phaetus x Voron Dragon Hotend ST)
DIY MK4 + VORON Stealthburner (BTT SKR PRO V1.1 + RPi Zero 2 W)
procesor82

Re: Rozwiązania i problemy przy budowie siboor Voron 2.4 350

Post autor: procesor82 »

W komentażu pisze że jeśli uruchomisz obydwa to priorytet bedzie na wifi, zdecydowanie obydwa mogą działać bo po uruchomieniu armbian mogę przez armian-config dokonac połączenia wifi lub lan odepne lan jest wifi tylko po restarcia robi sie kicha.Wszystko to robiłem działa do momentu ponownego rozruchu i wtedy nie działa nic tak jakby nie podnosił wifi i nie łączy po restarcie ani do lan ani do wifi zmiana spowrotem na lan w tym pliku nic nie daje lan już się nie podnosi. :)
Awatar użytkownika
fesou
Postów w temacie: 4
Posty: 229
Rejestracja: 10 wrz 2019, 10:19
Lokalizacja: Kraków i okolice
Drukarka: Ender 5 (upgr)
x 163

Re: Rozwiązania i problemy przy budowie siboor Voron 2.4 350

Post autor: fesou »

Może głupie, ale wyłącz ochronę ruchu sieci w antywirusie na kompie - może to po innej stronie połączenia jest problem - mi eset od czasu do czasu robi jaja z kontaktemnz drukarkami, ale wszystko mam tan na auto
VORON V2.4 (serial V2.5527) ::enderON 5/Legacy/Trident :: MPCNC printer under constr.
procesor82

Re: Rozwiązania i problemy przy budowie siboor Voron 2.4 350

Post autor: procesor82 »

fesou pisze: 13 wrz 2023, 08:16 Może głupie, ale wyłącz ochronę ruchu sieci w antywirusie na kompie - może to po innej stronie połączenia jest problem - mi eset od czasu do czasu robi jaja z kontaktemnz drukarkami, ale wszystko mam tan na auto
Nie widać go na routerze nie chodzi o pc ale próbuje z nowym obrazem chyba wcześniej popełniłem błąd i odpale conf na nowo zobaczymy czy wyjdzie.
procesor82

Re: Rozwiązania i problemy przy budowie siboor Voron 2.4 350

Post autor: procesor82 »

nmcli con add con-name "Armbian wireless" tysudope wifi ifname wlan0 ssid "$FR_net_wifi_ssid" -- wifi-sec.key-mgmt wpa-psk wifi-sec.psk "$FR_net_wifi_key" ${FIXED_IP_SETTINGS}
Error: invalid <setting>.<property> 'tysudope'.
teraz mam taki error
ODPOWIEDZ

Wróć do „Pomoc i wsparcie”