Anycubic i3 Mega - Klikający ekstruder gubiący kroki

Jakość druku Cię nie zadowala?
Owner
Posty: 4
Rejestracja: 11 lut 2019, 12:23

Anycubic i3 Mega - Klikający ekstruder gubiący kroki

Postautor: Owner » 11 lut 2019, 12:42

Mam problem z drukarką Anycubic i3 Mega.

Silnik krokowy od ekstrudera gubi kroki i "cofa" filament. Usterka objawia się chwilę po uruchomieniu wydruku, czasem dopiero po 30min.
Film obrazujący problem: https://youtu.be/bobpjBt2xb4?t=11

Wymieniłem:
- Sterowniki silników krokowy na TMC 2208
- Zmieniałem napięcie na sterownikach od 0.86V do 1.2V
- Hotend na V6 E3D
- Wymieniłem "złotą śrubę" z ekstrudera
- Zwiększenie przepływu powietrza przez sterowniki silników krokowych
- Zamiana silnika krokowego z osi X


Od 2 miesięcy kontaktuję się z supportem od Anycubic i jeszcze nie udało się znaleźć przyczyny problemu.

Co może być przyczyną tej usterki?
Awatar użytkownika
dragonn
Zasłużony
Posty: 4687
Rejestracja: 12 gru 2016, 21:50
Lokalizacja: Opole
Drukarka: LUME
x 600

Re: Anycubic i3 Mega - Klikający ekstruder gubiący kroki

Postautor: dragonn » 11 lut 2019, 12:48

V6 E3D jest oryginalny czy podróbka?
LUME PRO - mody: E3D Lite6 w bowden + Titan, silniki 42BYGHM809
Owner
Posty: 4
Rejestracja: 11 lut 2019, 12:23

Re: Anycubic i3 Mega - Klikający ekstruder gubiący kroki

Postautor: Owner » 11 lut 2019, 13:55

Oryginalny z silikonową skarpetą. Po wymianie kalibrowałem również współczynniki DEFAULT_Kp DEFAULT_Ki DEFAULT_Kd.
Korzystałem z pomocy tutoriala: https://youtu.be/lMmpn39Hdko?t=1681
sp6vgx
Posty: 415
Rejestracja: 06 lut 2018, 18:38
Lokalizacja: Warszawa
x 62
Kontaktowanie:

Re: Anycubic i3 Mega - Klikający ekstruder gubiący kroki

Postautor: sp6vgx » 11 lut 2019, 14:34

Wiem że zmieniłeś hot-end, ale ja bym dobrze sprawdził PTFE bo to wygląda jak by ci się gdzieś ten filament czopował i ekstruder nie daje rady. To zresztą można ręcznie sprawdzić tzn. w momencie jak się blokuje sprawdzić ręką czy jaką trzeba użyć siłę do przepchania filamentu.
For every complex problem, there is a solution that is simple, neat, and wrong.
Ultimaker 1 i 1/2, Szrotek, Vertex K8400, Anycubic I3 Mega
Owner
Posty: 4
Rejestracja: 11 lut 2019, 12:23

Re: Anycubic i3 Mega - Klikający ekstruder gubiący kroki

Postautor: Owner » 12 lut 2019, 10:10

@sp6vgx Faktycznie jak wsuwam filament to na ostatnich 5cm czuję lekki "przeskok/opór". Tak jakby rurka była zagięta albo jakbym nie wcisnął jej do końca.

Rozebrałem cały hotend. Hotend jest w środku czysty, mogę przejrzeć całą głowicę na wylot. Nie wiem skąd ten opór, mógł się brać.
Po złożeniu wszystko wydawało się ok. Chwilę po uruchomieniu drukarki ekstruder ładnie podawał filament. Wypływał piękną spiralą (załącznik IMG_20190211_174912.jpg). Już byłem pewien, że może to było to...

...ale po ~30min znowu zaczął przeskakiwać. Z początku raz na 30sec, później coraz częściej co ~3sec. Ale jak się blokuje, to nawet gdy ręcznie pomagam dopychać filament to czuję, że jest jakiś opór. Więc myślę, że to jest dobry trop.
Załączniki
IMG_20190211_174912.jpg
Awatar użytkownika
dragonn
Zasłużony
Posty: 4687
Rejestracja: 12 gru 2016, 21:50
Lokalizacja: Opole
Drukarka: LUME
x 600

Re: Anycubic i3 Mega - Klikający ekstruder gubiący kroki

Postautor: dragonn » 12 lut 2019, 10:19

Silnik lub stepstick się czasem nie przegrzewa?
Jakie wartości retrakcji ustawiłeś?
LUME PRO - mody: E3D Lite6 w bowden + Titan, silniki 42BYGHM809
Owner
Posty: 4
Rejestracja: 11 lut 2019, 12:23

Re: Anycubic i3 Mega - Klikający ekstruder gubiący kroki

Postautor: Owner » 12 lut 2019, 14:57

@dragonn wartości retrakcji faktycznie miałem ustawione za duże (4 mm). Podczas składania Hotendu V6 pominąłem krok nr 33, aby zmniejszyć długość retrakcji do 1 mm.

"Do not increase the retraction length more than 2mm as this can lead to molten plastic being pulled into the heat break, increasing the likelihood of jams."
https://e3d-online.dozuki.com/Guide/V6+Assembly/6#s570



Wygenerowałem nowy gcode i wszystko szło gładko do 23minuty (akurat ostatnie 3 warstwy). Gdy od razu wystartowałem nowy wydruk, to silnik momentalnie zaczął gubić krok. Nie dziwie się, bo nawet ręcznie ciężko jest wypchnąć filament. Faktycznie jakby coś się blokowało w głowicy.
IMG_20190212_141919.jpg

IMG_20190212_144254.jpg


Silnik wydaje się ok, ledwie wyczuwalne ciepło.
Co do stepstick, to próbowałem już zwiększyć przepływ powietrza przez zdemontowanie dolnej pokrywy i postawienie drukarki na 5cm podwyższeniu. Sprawdzę jeszcze raz napięcie referencyjne na sterowniku do silnika krokowego, czy przypadkiem nie zostawiłem na 1.2V. Jak coś to zmniejszę do ~0.86V i zamienię go ze stepstick z innej osi i jeszcze raz zdemontuję dolną pokrywę.

Podmienię również rurkę PTFE, może źle ją uciąłem. Teraz robię wydruk "na zimnej" drukarce sprawdzę, czy to sterownik, czy może jednak coś się przytyka w głowicy.
sp6vgx
Posty: 415
Rejestracja: 06 lut 2018, 18:38
Lokalizacja: Warszawa
x 62
Kontaktowanie:

Re: Anycubic i3 Mega - Klikający ekstruder gubiący kroki

Postautor: sp6vgx » 12 lut 2019, 15:24

Ja akurat na ekstruder zostawiłem oryginalny stepstick (ot stwierdziłem że w tym miejscu jest mała różnica - bardziej słychać łożyska), ale to w zasadzie nie powinno przeszkadzać i TMC powinien sobie radzić. Nie pamiętam jak mam ustawione napięcia ale coś w okolicach 1V wiem że w okolicach 0.9V miałem czasem gubienie kroków na osiach (w sumie starałem się ustawić jak najmniejszy prąd dla silników aby nie gubiły kroków).

W sumie jak podmieniałeś silnik itd. ja bym raczej tutaj nie szukał przyczyny. Możesz jeszcze zamiast złączki pneumatycznej wydrukować coś takiego https://www.thingiverse.com/thing:2755127 - możliwe że nie trzyma idealnie rurki PTFE i ta się lekko cofa. Inna sprawa to wiadomo równe docięcie - ale tutaj widać że sobie radzisz i z rozbieraniem itp. więc raczej takiego babola chyba nie zrobiłeś.
For every complex problem, there is a solution that is simple, neat, and wrong.
Ultimaker 1 i 1/2, Szrotek, Vertex K8400, Anycubic I3 Mega
Martin
Posty: 77
Rejestracja: 16 wrz 2017, 08:02
Lokalizacja: Warszawa
Drukarka: Anycubic i3 Mega
x 18

Re: Anycubic i3 Mega - Klikający ekstruder gubiący kroki

Postautor: Martin » 12 lut 2019, 20:42

A może to kwestia chłodzenia radiatora hotendu? Ja miałem sytuację, że jak dół radiatora się nie chłodził poprawnie to po pewnym czasie druku filament zaczynał stawiać opór. Czy jest różnica do wystąpienia objawów, jak wyciągasz filament po wydruku vs jak zostaje po druku w hotendzie i puszczasz następny wydruk?
———
Anycubic i3 Mega
Delta Phineas 3DP
Awatar użytkownika
@GUTEK@
Posty: 249
Rejestracja: 02 lip 2018, 21:45
Lokalizacja: Gliwice
Drukarka: Creality CR-10 bez S
x 57
Kontaktowanie:

Re: Anycubic i3 Mega - Klikający ekstruder gubiący kroki

Postautor: @GUTEK@ » 12 lut 2019, 22:00

A jaki masz łącznik w tym E3D V6 i z jakiego typu filamentu drukujesz ?

Wróć do „Kalibracja, problemy”

Kto jest online

Użytkownicy przeglądający to forum: Google [Bot], virgin71 i 5 gości