TMC2209 problem uart. MKS robin nano

Jakość druku Cię nie zadowala?
damianqx
Posty: 219
Rejestracja: 27 mar 2019, 00:59
x 9

Re: TMC2209 problem uart. MKS robin nano

Postautor: damianqx » 10 mar 2020, 16:35

rafaljot pisze:hmmm.... różnice są dwie:
1. w rezystorze R1 zerującym pin na MS1
2. w Robin zwarte na stałe piny RST i SLEEP, którą w trybie UART w SKR PRO należy wyjąć ( https://github.com/bigtreetech/BIGTREET ... 20v1.1.pdf)

może należy wylutować od dołu testowo PINY MS1, MS2, MS3, RST


Wylutować w tmc tak ?
Awatar użytkownika
Berg
Zasłużony
Posty: 6879
Rejestracja: 05 lis 2016, 11:57
Lokalizacja: Kraków
Drukarka: Lume, K8400, HC Evo
x 2262

Re: TMC2209 problem uart. MKS robin nano

Postautor: Berg » 10 mar 2020, 16:37

tak
SLEEP chyba też
damianqx
Posty: 219
Rejestracja: 27 mar 2019, 00:59
x 9

Re: TMC2209 problem uart. MKS robin nano

Postautor: damianqx » 10 mar 2020, 17:39

Wylutowałem te 5 pinów i nadal nic.
Już nie wiem o co chodzi. Ten gościu ArturPetrzak z yt twierdzi że wystaczy wyciągnąć zworki pod stepami i podłączyć przewodami bez rezystora nawet i mu działa na tej płycie. A u mnie jak mocno sie bym nie starał to nie działają... Więc nie wiem w czym już problem
Awatar użytkownika
Berg
Zasłużony
Posty: 6879
Rejestracja: 05 lis 2016, 11:57
Lokalizacja: Kraków
Drukarka: Lume, K8400, HC Evo
x 2262

Re: TMC2209 problem uart. MKS robin nano

Postautor: Berg » 10 mar 2020, 18:35

link?
damianqx
Posty: 219
Rejestracja: 27 mar 2019, 00:59
x 9

Re: TMC2209 problem uart. MKS robin nano

Postautor: damianqx » 10 mar 2020, 18:38

To na grupie fb
Załączniki
123.PNG
456.PNG
Awatar użytkownika
Berg
Zasłużony
Posty: 6879
Rejestracja: 05 lis 2016, 11:57
Lokalizacja: Kraków
Drukarka: Lume, K8400, HC Evo
x 2262

Re: TMC2209 problem uart. MKS robin nano

Postautor: Berg » 10 mar 2020, 20:27

Zerknę u siebie czy tam coś nie jest pomylone względem schematu. Też pamiętam jakiś wątek w którym ktoś przerabiał pomylone piny ale to chyba inny driver był.
Pewnie coś w sofcie masz nie tak...
W trybie standalone one dalej działają?
Na pewno masz zasilanie +12/24V na pinie vmot w trakcie sprawdzania, czy działa ?
damianqx
Posty: 219
Rejestracja: 27 mar 2019, 00:59
x 9

Re: TMC2209 problem uart. MKS robin nano

Postautor: damianqx » 10 mar 2020, 20:51

Zasilanie jest, drivery działają w normalnym trybie bez znaczenia czy w configu mam standalone czy nie. Po prostu pokazuje błąd komunikacji i driver żyje swoim życiem na podstawie potencjometru.

Z tymi pomylonymi pinami to problem był chyba w któryś fystec. W btt jest okej chyba

Soft powinien być okej ale pewności nie mam, bardzo możliwe że tak jest.
Piny mam wpisane w pliku z pinami i do nich się podpinam(zakomentowane są bo próbowałem ruszyć chociaż jednego)
Załączniki
piny.PNG
Awatar użytkownika
Berg
Zasłużony
Posty: 6879
Rejestracja: 05 lis 2016, 11:57
Lokalizacja: Kraków
Drukarka: Lume, K8400, HC Evo
x 2262

Re: TMC2209 problem uart. MKS robin nano

Postautor: Berg » 10 mar 2020, 22:28

pewnie już zamieniałeś w configu #define X_SERIAL_TX_PIN z RX_PINem
damianqx
Posty: 219
Rejestracja: 27 mar 2019, 00:59
x 9

Re: TMC2209 problem uart. MKS robin nano

Postautor: damianqx » 11 mar 2020, 07:01

Dokładnie tak, próbowałem też uzyc innych pinów
damianqx
Posty: 219
Rejestracja: 27 mar 2019, 00:59
x 9

Re: TMC2209 problem uart. MKS robin nano

Postautor: damianqx » 15 mar 2020, 22:53

Nie udało mi się tego zrobić, odpusciłem i kupiłem klon dueta
Berg

Wróć do „Kalibracja, problemy”

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 14 gości